Get currently running NodeJS version

Ori Goren-Bar 阳锐
Ori Goren-Bar 阳锐
  • Updated
API endpoint: GET /api/node_version
Sample Response:
{"current":{"options":{"loose":false,"includePrerelease":false},"loose":false,"raw":"v12.16.1\n","major":12,"minor":16,"patch":1,"prerelease":[],"build":[],"version":"12.16.1"},"satisfied":true,"recommended":">=10.0"}
 
Shell
curl "http://127.0.0.1:22999/api/node_version"

Node.js

#!/usr/bin/env node
require('request-promise')({
	url: 'http://127.0.0.1:22999/api/node_version'
}).then(function(data){ console.log(data); },
	function(err){ console.error(err); });

Java

package example;

import org.apache.http.HttpHost;
import org.apache.http.client.fluent.*;

public class Example {
  public static void main(String[] args) throws Exception {
    String res = Executor.newInstance()
.execute(Request.Get("http://127.0.0.1:22999/api/node_version"))
.returnContent().asString(); System.out.println(res) }
}

C#

using System;
using System.Net;
using System.Net.Http;
using System.Net.Http.Headers;

public class Program {
  public static async Task Main() {
    var client = new HttpClient();
    var requestMessage = new HttpRequestMessage {
      Method = HttpMethod.Get,
RequestUri = new Uri("http://127.0.0.1:22999/api/node_version") }; var response = await client.SendAsync(requestMessage); var responseString = await response.Content.ReadAsStringAsync(); Console.WriteLine(responseString); } }

Python

#!/usr/bin/env python
print('If you get error "ImportError: No module named requests", please install it:\n$ sudo pip install requests');
import requests

r = requests.get('http://127.0.0.1:22999/api/node_version')
print(r.content)
Share this

Was this article helpful?

0 out of 0 found this helpful