如何在 Linux 或 MacOS 系统上安装代理管理器 (PM)

Ori Goren-Bar 阳锐
Ori Goren-Bar 阳锐
  • 更新于

如果您想在 Linux 或 MacOS 服务器或电脑上安 PM,请:

  • 确认推荐的硬件要求:4GB RAM 2 个 CPU 3GB SSD

  • 确认推荐的软件要求:
    • 注意:无法使用 Linux CentOS 8.x(请改用 CentOS 7.x !)
    • Node.js 支持的版本:12.18.3 - 14.18.1(不支持其它版本)
      (在终端中输入 node -v 来确认已装的版本)
    • NPM 支持的版本:6.14.6 - 8.1.3(不支持其他版本)
      (在终端中输入 npm -v 来确认已装的版本)

      重要通知: 

      如果您在国内的 Linux/MacOS 上安装 PM,为了确保使用允许的注册表参数安装 NPM,请运行:
      npm config set registry https://r.cnpmjs.org/sudo npm install -g npm@6.14.6
  • 确认网络流量不受限制:
    • 服务器/电脑不在使用任何 VPN 或代理 IP!
    • 操作系统防火墙已关闭
    • TCP 端口 20000-30000 允许进出流量

  • 来安 PM从终端运行:
sudo npm install -g @luminati-io/luminati-proxy --allow-root

如果如上的命令失败了,尝试运行如下命令之一:

curl -L https://brightdata.com/static/lpm/luminati-proxy-latest-setup.sh | bash
wget -qO- https://brightdata.com/static/lpm/luminati-proxy-latest-setup.sh | bash

您可以找到更多信息:
https://github.com/luminati-io/luminati-proxy#linuxmacos---manual-install